
1. Overview
        In this tutorial, I will first introduce Cum at Will and the softwares it relies on, as well as how to install 
and configure these softwares. Then we'll have a quick preview of the basic workflow of generating liquids 
for NG9. At the end, I will further explain the use of Cum at Will with a few examples. 

2. Cum at Will and the softwares it relies on
        Cum at Will is a toolkit I created that cover the entire process of creating liquids for NG9. In DAZ 
Studio, CAW's DAZ script adapts NG9 for the liquid generation by applying components and morphs. Then 
your scene including NG9 will be imported into Blender via Diffeomorphic's DAZ Importer. CAW's Blender 
add-on will automatically set up all the necessary fluid simulation parameters for the liquid. You just need 
to modify a few parameters in the add-on's UI to get a customized liquid model and export it. After 
returning to DAZ Studio, you can give the liquid model different materials according to your needs, such as 
water material or semen material, and do the final rendering. 

3. Installation
        3.1 Blender
        Cum at Will uses Blender's fluid simulation system to generate the liquid models. So first we need to 
install Blender on our computer, this powerful software is free and you can download it from the following 
URL: 
        https://www.blender.org/download/releases/
        Please install Blender 4.0 and above, or Blender 3.6 LTS version. We do not need to configure 
Blender, as long as it starts properly. 
        3.2 Diffeomorphic
        Diffeomorphic is a great and free toolkit by Alessandro Padovani and Thomas Larsson. Its DAZ 
Importer add-on can help us quickly import entire DAZ Studio scene into Blender. Please download the 
latest stable version of this add-on from the following URL: 
        https://bitbucket.org/Diffeomorphic/import_daz/wiki/Home
        This page also contains a detailed installation and usage tutorial for the Diffeomorphic. Since we only 
need to use DAZ Importer, here I'll excerpt the installation steps of it:

a. In the zip file we downloaded, there are two sub-folders, one of which is 'import_daz', which is the 
DAZ Importer we need. 

        Double-click to enter the 'import_daz' subfolder, then you can see a subfolder called 'to_daz_studio', 
which contains the part of DAZ Importer that runs in DAZ Studio (DAZ scripts). There is a separate folder 
called 'Scripts' under this subfolder. Copy this 'Scripts' folder to one of your DAZ Studio library folders. 



b. Now start DAZ Studio. In the Content Library pane, open the Scripts folder and then the
Diffeomorphic subfolder. It contains six scripts. 



c. Double-click on the script 'Setup Menus' and 4 new menu items will be added to DAZ Studio's File
menu. These menu items link to the scripts in the Diffeomorphic subfolder. So in the future we will be able 
to quickly execute these scripts from the File menu, which is very convenient. 

d. The part of DAZ Importer that runs in Blender (Blender add-on) needs to know the paths to all the
DAZ assets in order to import the DAZ Studio scenes into Blender properly. So all the root paths of DAZ 
Studio need to be passed to Blender via a JSON file. In the File menu of DAZ Studio select 'Save Root 
Paths' and then select a folder to save the JSON file in the file selection window that pops up. 



e. Next, we will install and configure the Blender add-on for DAZ Importer. Open Blender, click 'Edit >
Preferences...' to open the Blender Preferences window. In the Add-ons tab, press the 'Install...' button to 
open the file selector. Navigate to the downloaded zip file and press 'Install Add-on'. 

f. The add-on is now copied to your Blender add-ons folder. Select the checkbox on the left to enable
the DAZ importer. Then a new tab named 'DAZ Setup' now appears in the UI panel to the right of the 
viewport. 



g. Click the DAZ Setup tab. Press the 'Global Settings' button to open the settings dialog, and then
press the 'Load Root Paths' button. In the file selector, find the JSON file with the root paths that you save 
in DAZ Studio before. At last, press the 'Load Root Paths' button. 



        3.3 The Daz props for Cum at Will
        Extract the Cum at Will zip file to a temporary folder and get two new zip files, CAW_daz_studio.zip 
and CAW_blender.zip.  

        Similar to Diffeomorphic, Cum at Will is also divided into a part that runs in DAZ Stduio and a part 
that runs in Blender. Let's install CAW's Daz props first, double-click to open 
CAW_daz_studio.zip, copy the 'data' folder and the 'People' folder to the DAZ Studio library folder where 
NG9 is located. 



        Once the copy is complete, start DAZ Studio and in the Content Library pane, open 'People > Genesis 
9> Anatomy > New Genitalia for Genesis 9 > Cum at Will'. You will see two scripts:



        CAW - Apply Components
        Add the components required to generate liquid to NG9.
        CAW - Remove components
        Completely remove the components from the scene.
        In addition, Cum at Will also brings some new morphs to NG9. Select NG9 and go to the Parameters 
pane and you will see these morphs in 'Actor > 07 - CAW': 

        0701 - Base Pose
        Because Blender's fluid simulation is physically realistic, the liquid may collide with the clitoris, labia, 
etc. and change direction, preventing you from obtaining the desired liquid shape. In response, this morph 
automatically takes effect and changes the NG9's external shape so that the liquid flow from the urethra, 
vagina, or anus is not obstructed. 

        0702 - Urethra
        This morph will transform the urethra part of NG9 into a container, and the liquid will flow out of the 
opening of this container, the urethra orifice. 



        0704 - Vagina
        This morph will transform the vaginal part of NG9 into a container, and the liquid will flow out of the 
opening of this container, the vaginal opening. 

 0706 - Anus
 This morph will transform NG9's anus and rectum into a container, and the liquid will flow out of the 

opening of this container, the anus. 
       The other morphs are used to adjust the rotation angle of corresponding parts or correct the shape of 
NG9, and are only used in specific situations. Therefore, I will introduce these morphs when they are used 
in the examples.

        3.4 The Blender add-on for Cum at Will
        Open Blender, click 'Edit > Preferences...' to open the Blender Preferences window. In the Add-ons 
tab, press the 'Install...' button to open the file selector. Navigate to the 'CAW_blender.zip' and press 
'Install Add-on'. 

        The add-on is now copied to your Blender add-ons folder. Select the checkbox on the left to enable 
the Cum at Will add-on.



        Then a new tab named 'Cum at Will' now 
appears in the UI panel to the right of the viewport. 



4. General workflow for using CAW
        4.1 Creating your scene
        First, create your scene in DAZ Studio as usual. After the scene is created, save the scene and then 
save it as a copy for exporting to Blender to generate the liquid. The next work will be carried out in this 
replica scene. The reason for this is because after installing Cum at Will, NG9 got some new morphs. Before 
exporting the scene to Blender, we need to use these morphs to do some morphing on the NG9. This may 
break the look you set for NG9 when you create the original scene. So using a replica scene is a good idea.  

        4.2 Adding the components to NG9
        Select NG9 or the character NG9 belongs to in the Scene pane. Go to the Content Library pane, open 
'People > Genesis 9 > Anatomy > New Genitalia for Genesis 9 > Cum at Will' and double-click the 'CAW - 
Apply components' icon. The script will add two components to NG9:

CAW Liquid Source
        This component is a small sphere. When the scene is imported into Blender, the sphere will serve 
as the source of the liquid.         

CAW Liquid Domain
        This component is a cube and the CAW Liquid Source must always be located inside this cube. During 
the fluid simulation, liquid will only exist inside the CAW liquid domain. Cum at Will's default setting is that 
liquid that exceeds the boundaries of the cube will disappear.



        After these two components have been added to NG9, we need to dial the corresponding CAW 
morphs. For example, if you want to get the liquid flowing out of urethra, you need to dial '0702 - Urethra' 
to 100%, then select the CAW Liquid Source and move it to the inside of the 'container' formed by this 
morph. This way in Blender, liquid will be generated inside this 'container' and then flow out of the urethra. 

        Tips: Cum at Will can only create one type of the liquid flowing from one body part at a time. If you 
want to render the liquids from different parts at the same time, you can use CAW to create them 
separately. And then import all liquid models into the same scene for rendering.

        4.3 Importing the replica scene into Blender
        After setting up the components and morphs, save this replica scene. Then in the File menu of DAZ 
Studio, select 'Export To Blender'. This will export a .dbz file with the same name as the .duf file of the 
replica scene, and located in the same directory.



        Start Blender and click 'DAZ Setup' in the UI panel to the right of the viewport. Press ‘Easy Import 
DAZ’ button to open the file selector. Navigate to the directory where the replica scene you saved before. 
Select the .duf file of the replica scene and press ‘Easy Import DAZ’ button to import it into Blender. 



        4.4 Using the Cum at Will add-on
        After the replica scene has been successfully 
imported into Blender, click on 'Cum at Will' in the UI 
panel to the right of the viewport. You will see the 
four main buttons of the CAW add-on.
            4.4.1 Apply Fluid
            By pressing the 'Apply Fluid' button, the CAW   
add-on automatically sets up all the fluid simulation 
parameters for the NG9 in the scene. The other 
buttons are only available after pressing this button. 



            4.4.2 Apply Rotation
            In Blender's fluid simulation system, the direction of gravity changes as the fluid domain rotates. If 
you rotate the CAW Liquid Domain, the direction of gravity is no longer straight down. This can have some 
bad effects on the direction of the liquid. So when this happens, you need to press 'Apply Rotation' to fix 
the problem. Please note that you only need to press this button once after each rotation of the CAW Liquid 
Domain.

            4.4.3 Setup Fluid
            Pressing this button brings up the 'Setup Fluid' 
sub-panel. This sub-panel integrates part of the 
parameters of the Blender fluid simulation system. Here, 
you can modify the initial speed and direction of the 
liquid, the liquid shape, and set which objects in the 
scene the liquid will collide with.



            Initial Velocity and Direction
            In Blender's fluid simulation system, the initial direction of a liquid is determined by a combination 
of its initial velocity components in the X, Y, and Z directions, as well as the force of gravity (and even 
other forces). If we leave these initial velocity components at 0, the liquid will fall vertically onto the inner 
wall of the 'container' under the force of gravity alone. So after pressing the 'Apply Fluid' button, we need 
to go here to set the initial velocity and direction of the liquid.

            Resolution Divisions
            This parameter represents the resolution of the fluid domain (CAW Liquid Domain). The higher its 
value, the smaller the size of the particles that make up the liquid, and it will also cause the simulation 
speed to become slow.  In general, 100 is an appropriate value and does not need to be changed.

            Time Scale
            This parameter is used to adjust the speed of the simulation. 

            CFL Number
            Greater CFL numbers will minimize the number of simulation steps and the computation time.

            Timesteps Minimum
            Minimum number of simulation steps to perform for one frame. 

            System Maximum
            This parameter represents the maximum number of particles in the simulation. 0 means that the 
number of particles is unlimited.

            Viscosity Base
            This parameter is combined with the Viscosity Exponent below to control the viscosity of the 
liquid. For example, if you want the liquid to have the viscosity of water, you need to set this parameter 
to 1 and set the Viscosity Exponent to 6. This means that the viscosity of water in Blender is 1 x 10-6 
(0.000001).

            Viscosity Exponent
            See Viscosity Base.

 

 



            Mesh Scale
            This parameter determines the resolution of the generated liquid model. The higher its value, the 
more polygons the liquid model has and the more detailed the shape of the liquid.

            Mesh Partical Radius
            This parameter needs to increase with the increase of Mesh Scale, and vice versa.

            Gravity Weight
            As mentioned earlier, gravity is also one of the factors that determines the direction of liquids. In 
some cases, such as when we want a liquid to move upward, the liquid needs to overcome the influence of 
gravity. If the weight of gravity is appropriately reduced at this time, it will be easier for us to obtain the 
desired results.

            Selecting collision objects
            If you want the liquid to collide with certain objects in the scene during the simulation. Just find 
these objects in the object list and check the checkbox to the left of their name.

            Please note: After setting the above parameters, you must press the 'OK' button for all settings to 
take effect.

            4.4.4 Performing fluid simulation
            Now press the 'Play Animation' button at the bottom of the viewport to start the fluid simulation.

            At this point, the 'Play Animation' button will change to 'Pause' button and the frame slider will 
move forward.



            Observe the changes in the liquid in the viewport. If you are satisfied with the shape of the liquid 
in a certain frame, press the Pause button and drag the frame slider back to that frame.

            Please note that to save your time, Cum at Will only simulates up to 30 frames. If you cannot 
obtain a satisfactory liquid shape within these 30 frames, it means that you need to return to the 'Setup 
Fluid' panel to adjust the fluid parameters. After the adjustment is completed, press the 'Jump to Endpoint' 
button at the bottom of the viewport to return to the first frame, and then press the 'Play Animation' button 
to restart the simulation.

            4.4.5 Export Fluid
            After pausing the simulation and dragging the frame slider to the frame you are most satisfied 
with, click 'Cum at Will' in the UI panel to the right of the viewport. In the CAW's UI, press the button to 
the right of the Output Path field to open the file selector, select a file path and press the 'Accept' button. 
At last, press 'Export Fluid' in the CAW UI. The liquid model in the frame you selected will be exported as 
an .obj file and saved to the path you specified. 
            Note that you can also manually enter the file path in the Output Path field.



Tips: In fact, Blender’s fluid simulation parameters are much more than what you see in the 
Setup Fluid sub-panel. But after a long period of deliberation, I decided that the rest parameters should be 
automatically handled by the Cum at Will add-on to ensure that the simulation can be successful. If you are 
interested, you can go to Blender's Physics tab to find and test these parameters yourself. 

        4.5 Importing the liquid model into DAZ Studio
        Go back to DAZ Studio and reload your scene. Please note that you need to load the original scene 
here and not the copy used to generate the liquid. Next select 'Import...' from the File menu in DAZ Studio. 
Navigate to the directory where the .obj file is located. The filename format of the .obj file for the liquid 
model is: name of the replica scene + '_frame_' + frame number. Find the .obj file you just exported and 
press the 'Open' button.  



        4.6 Final Rendering
        Before starting the final render, we 
need to give the liquid model a material. 
First select the liquid model in the scene, 
then go to the Surfaces pane to select all 
its surfaces. 
        Next, it depends on what kind of 
liquid you want. If it is water, go to the 
Content Library pane and select the 
default library folder of DAZ Studio, 
usually ’My DAZ 3D Library‘. Double-click 
on the water preset's icon under its 
subfolder 'Shader Presets > Iray > DAZ 
Uber'.

        In the 'OBJ Import Options' window, 
select the preset: DAZ Studio (1 unit = 1 
cm). At last, press the 'Accept' button to 
import the liquid model into your scene. 



        If it's semen, open 'People > 
Genesis 9 > Anatomy > New 
Genitalia for Genesis 9 > Cum at Will 
> Shader Presets' in the Content 
Library pane, and double-click the 
semen preset icon. 

        Now, we can start the final 
rendering.

5 Examples
        Next, I will further explain the usage of CAW through some examples.
        5.1 Example 1
        In this example, we are going to create a scene where liquid spurts out of one character's urethra 
and splatters into another character's face. The following are steps:

            a. First create the scene. Load two characters and apply NG9 to the character who is going to 
squirt, then pose them. Pay attention to setting the distance between the two characters so that the liquid 
can reach the other character's face.

b. Save the scene as promo01.duf, then save it again as promo01_liquid.duf.
c. Make sure the scene loaded now is promo01_liquid. Select the character who is going to squirt 

in the Scene pane, double-click the 'CAW - Apply components' icon to add the CAW components 
to NG9. 



d. The liquid will be coming out of the urethra. Select NG9 in the Scene pane, then go to the
Parameters pane and select 'New Genitalia for Genesis 9 > Actor > 07 - CAW'. We can see that in the 
morph list on the right, '0701 - Base Pose' has been automatically dialed to 100%. We need to find '0702 - 
Urethra' and dial it to 100%, thus forming a 'container' inside the character's body.

e. From the side view, the angle of the 'container' seems to require some elevation. So I dialed
'0703 -Urethral - X Rotation' to almost 18%.

f. Select the CAW Liquid Source in the Scene pane and move it to the inside of the 'container'.



            g. Save this promo01_liquid scene. Select 'Export to Blender' in the file menu, and then press the 
'Save' button in the pop-up dialog box.



            h. Start Blender, click 'DAZ Setup' in the UI panel to the right of the viewport. Press 'Easy Import 
DAZ' button to open the file selector. Navigate to the directory where the promo01_liquid.duf is located. 
Select promo01_liquid.duf and press the 'Easy Import DAZ' button to import the scene into Blender.

            i. Click 'Cum at Will' in the UI panel to the right of the viewport., then press 'Apply Fluid' in CAW's 
UI. You can see that after applying fluid, the scene changes and the CAW Liquid Domain cube disappears 
from the scene.



            This indicates that the liquid has been successfully generated, and the next step is to get it to 
spray into the other character's face.

j. Observing the direction of the 'container', we found that the liquid needs to have initial velocities
in both negative Y and positive Z directions in order to finally reach the other character's face. Therefore, 
press 'Setup Fluid' in the CAW UI, then experimentally set the speed in the Y direction to -1m/s and the 
speed in the Z direction to 4m/s, and check 'Sarah HD for G9 Feminine' in the object list (another 
character's mesh) and 'Voss Hair Genesis 9' (another character's hair mesh). At last, press the 'OK' button.

k. Press the 'Play Animation' button at the bottom of the viewport to start the fluid simulation. 
Observing the shape changes of the liquid during the simulation, it was found that the liquid failed to reach 
the ideal height.



            So I paused the simulation and returned to the 
Setup Fluid subpanel. Set the Y-direction speed to -3m/
s and the Z-direction speed to 3m/s. Set the Mesh 
Particle Radius to 0.9 to make the shape of the liquid 
closer to urine. Then change the Gravity Weight to 0.6 
to reduce the gravity constraints of the liquid. At last, 
press the 'OK' button. 

            l. Press the 'Jump to Endpoint' button at the 
bottom of the viewport to return to the first frame, and 
then press the 'Play Animation' button to restart the 
simulation. The results this time are better than before. 
Please note that we can keep repeating this adjustment 
process until we obtain satisfactory results. Now pause 
the simulation and drag the frame slider to the frame you 
like the best.



            m. Click 'Cum at Will' in the UI panel to the right of the viewport. In the CAW UI, press the button 
to the right of the Output Path field to open the file selector, select a file path and press the 'Accept' 
button. At last, press the 'Export Fluid' button in the CAW UI, and the liquid model in the current frame is 
exported as an .obj file and saved to the specified path.

            n. Go back to DAZ Studio and reload 
promo01.duf. Then select 'Import...' in the File 
menu of DAZ Studio. Navigate to the directory 
where the .obj file is located. Locate the .obj 
file you just exported and press the 'Open' 
button. In the 'OBJ Import Options' window, 
select the preset: DAZ Studio (1 unit = 1 cm). 
At last, press the 'Accept' button to import the 
liquid model into your scene. 



            o. Select the liquid model you just imported in the scene, and go to the Surfaces pane to select all 
its surfaces. Since these fluids come from the urethra, we go to the Content Library pane and select 
DAZStudio's default library folder, 'My DAZ 3D Library'. Double-click on the water preset's icon under its 
subfolder 'Shader Presets > Iray > DAZ Uber'.

            p. Do the final rendering.



        5.2 Example 2
        The steps of this example are 
basically similar to the first one. The 
difference is that there is only one 
character in the scene, and the liquid is 
sprayed at a different angle and at a 
higher height.
        So here we can continue to use the 
steps of Example 1. However, due to the 
two differences mentioned before:

a. When adjusting the angle of the 'container', we need to dial '0703 - Urethra - X Rotation' to its
maximum value of 100%. But at this time, part of the 'container' will come outside the character's body.



        Such a scene will not generate liquid if imported directly into Blender. In this case, we need to use 
another morph, '0711 - Urethra - X Correction' to correct it. First, dial the morph to 100% so that the 
'container' is located inside the character's body again, and then export the scene to Blender.

        You might be worried about the drastic changes that the correction morph brings to your character's 
body shape. Please don't worry, first of all we are working in a replica scene, enabling this morph will not 
affect your original scene. Secondly, in this example, the liquid will move away from the character and will 
not collide with the character's mesh, this morph will not affect the shape of the liquid.

b. After the replica scene has been imported into Blender and the CAW's 'Apply Fluid' button has been
pressed, the 'CAW Liquid Domain' cube does not disappear, indicating that the liquid was not successfully 
generated. The solution to this problem is very simple, we just need to keep changing the position of the 
'CAW Liquid Domain' slightly until the liquid is successfully generated. 

        To change the position of an object in Blender, first click to select the object in the viewport, and then 
select the 'Move' tool in the toolbar on the left side of the viewport. At this time, the movement axis will 
appear on the object. Move the mouse to the movement axis and hold down the left mouse button to drag 
the object. 



        5.3 Example 3
        This example shows the flow of liquid from 
the vagina onto the floor. 

        It is much simpler than the previous two 
examples in that we only need to give the liquid 
a small initial velocity so that they slowly flow 
out of the vagina and collide with the floor.
However, this example also has a point worthy 
of further explanation: setting the thickness of 
the obstacle. Some objects do not require 
thickness when used as obstacles, such as the 
character's mesh. Some objects require a 
certain thickness, such as floors and clothing, 
otherwise the liquid will pass directly through 
them instead of colliding with them. 



The CAW add-on can help us quickly set an 
object as an obstacle, but it does not know whether 
the thickness should be set for this object. At this time, 
we needs to make manual judgment based on the 
simulation results. 

To set the thickness of an object that has been 
set as an obstacle by CAW is very simple. All we need 
to do is select the object in the viewport, then go to 
the Physics tab to the right of the viewport and set 
'Surface Thickness' to 0.5 or higher. 

 5.4 Example 4
        As mentioned earlier, we can only create liquids flowing from one 
part at a time. However, we can make changes to the replica scene 
and continue to create the liquid from another part. After all the liquids 
are created, we can import all of them into the original scene for 
rendering.

        In this example, we can start 
by creating the liquid for NG9's 
vagina. Then go back to DAZ 
Studio and load the replica scene, 
set '0704 - Vagina' to 0%, set 
'0708 - Anus' to 100% and move 
the 'CAW Liquid Source' into the 
newly formed 'container'. Then 
saved the replica scene and 
exported it to Blender to create 
the liquid for NG9's anus. At last, 
load the original scene in DAZ 
Studio, import the two liquid 
models into the scene and give 
them the semen material. 



This way, we don't have to set an initial velocity for the liquids, just wait for them to slowly flow out 
of the vagina or anus under the influence of gravity. 

        There is a little trick in this example, when creating liquid from the vagina or when creating liquid 
from the anus, we can set the CAW morphs of NG9, '0707 - Vagina - Z Rotation - p30' or ' 0710 - Anus - 
Z Rotation - p30' to 100%, so that the 'container' becomes the angle as shown in the following picture:
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